Users may not be receiving notifications or password reset emails from Aha!
Incident Report for Aha!
Resolved
This incident has been resolved.
Posted Mar 01, 2022 - 16:06 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 01, 2022 - 15:30 UTC
Investigating
Users may not be receiving notifications or password reset emails from Aha! We are investigating the issue.
Posted Mar 01, 2022 - 15:29 UTC