Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 11, 2025 - 03:30 UTC
Scheduled
We will perform a system upgrade tonight at 11:30 ET. It could take up to fifteen minutes to complete the upgrade, and Aha! software might be unavailable for a very brief time period. There will be no additional impact if you are not using Aha! software at that time.
Posted Jul 11, 2025 - 03:06 UTC
This scheduled maintenance affected: Aha! application, Support website, and Webhook processing.