Degraded performance for some customers.

Incident Report for Aha!

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 14:25 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 28, 2026 - 14:00 UTC

Monitoring

Performance for some customers was degraded between 8:45 AM EST and 9:32 AM EST. Aha! Engineering has applied mitigations, and performance is now nominal. Engineering continues to monitor.
Posted Jul 28, 2026 - 13:36 UTC
This incident affected: Aha! application.