Slow performance for some requests and difficulty editing some records.
Incident Report for Aha!
Resolved
This incident has been resolved.
Posted Mar 02, 2022 - 20:43 UTC
Update
We are continuing to work on some slow performance.

Editing descriptions should be working for all users. If you see any issues, reloading the page should fix them.
Posted Mar 02, 2022 - 20:09 UTC
Investigating
We are observing that some pages and descriptions are failing to load or update for users.
Posted Mar 02, 2022 - 18:55 UTC
This incident affected: Aha! application.