Performance problems for EU data center customers
Incident Report for Aha!
Resolved
Performance has now returned to normal.
Posted Aug 24, 2023 - 18:34 UTC
Monitoring
Customers using the EU data center may have seen trouble loading some pages in Aha! or general slow performance.
Posted Aug 24, 2023 - 18:10 UTC
This incident affected: Aha! application.