Slow response times for some customers
Incident Report for Aha!
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 23:02 UTC
Identified
Aha! Engineering is aware of slow response time for the Aha! application for some customers within a single data center. Engineering is actively working on resolving the problem now.
Posted Mar 22, 2022 - 22:17 UTC
This incident affected: Aha! application.